라우터 1번 설정
-라우터 1번 설정 흐름-
Ruoter>enable
Router#config
Configuring from terminal, memory, or network [terminal]? t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname R1
R1(config)#no ip domain lookup
R1(config)#enable secret cisco
R1(config)#line console 0
R1(config-line)#no login
R1(config-line)#exec-timeout 0 0
R1(config-line)#logging synchronous
R1(config-line)#exit
R1(config)#line vty 0 4
R1(config-line)#no login
R1(config-line)#exit
R1(config)#interface loopback 0
R1(config-if)#ip
*Mar 1 00:04:42.171: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback0, changed state to up
R1(config-if)#ip address 10.10.10.0 255.255.255.0
Bad mask /24 for address 10.10.10.0
R1(config-if)#ip address 10.10.10.1 255.255.255.0
R1(config-if)#exit
R1(config)#interface serial 1/0
R1(config-if)#ip address 192.168.1.1 255.255.255.252
R1(config-if)#bandwidth 2048
R1(config-if)#en
R1(config-if)#encapsulation hdlc
R1(config-if)#no shutdown
R1(config-if)#e
*Mar 1 00:08:54.475: %LINK-3-UPDOWN: Interface Serial1/0, changed state to up
R1(config-if)#exit
R1(config)#
*Mar 1 00:08:55.483: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial1/0, changed state to up
R1(config)#interface serial 1/1
R1(config-if)#ip add
*Mar 1 00:09:17.379: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial1/0, changed state to down
R1(config-if)#ip address 192.168.1.5 255.255.255.252
R1(config-if)#bandwidth 2048
R1(config-if)#encapsulation hdlc
R1(config-if)#no shutdown
R1(config-if)#end
R1#
*Mar 1 00:10:31.079: %LINK-3-UPDOWN: Interface Serial1/1, changed state to up
R1#c
*Mar 1 00:10:32.179: %SYS-5-CONFIG_I: Configured from console by console
*Mar 1 00:10:32.183: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial1/1, changed state to up
R1#copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK]
R1#
*Mar 1 00:10:57.411: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial1/1, changed state to down
-설정이 되었는지를 확인-
R1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
10.0.0.0/24 is subnetted, 1 subnets
C 10.10.10.0 is directly connected, Loopback0
R1#
- 라우터 2번 설정 -
Router>enable
Router#config
Configuring from terminal, memory, or network [terminal]? t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname R2
R2(config)#enable secret cisco
R2(config)#no ip domain lookup
R2(config)#line console 0
R2(config-line)#no login
R2(config-line)#exec-timeout 0 0
R2(config-line)#logging synchronous
R2(config-line)#exit
R2(config)#line vty 0 4
R2(config-line)#no login
R2(config-line)#exit
R2(config)#interface fastethernet 0/0
R2(config-if)#ip address 172.11.0.1 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#in
*Mar 1 00:20:43.123: %LINK-3-UPDOWN: Interface FastEthernet0/0, changed state to up
*Mar 1 00:20:44.123: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
R2(config-if)#interface serial 1/0
R2(config-if)#ip address 192.168.1.2 255.255.255.252
R2(config-if)#bandwidth 2048
R2(config-if)#encapsulation hdlc
R2(config-if)#no shutdown
R2(config-if)#end
R2#
*Mar 1 00:22:09.187: %LINK-3-UPDOWN: Interface Serial1/0, changed state to up
R2#
*Mar 1 00:22:09.455: %SYS-5-CONFIG_I: Configured from console by console
*Mar 1 00:22:10.195: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial1/0, changed state to up
R2#copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK]
R2#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
172.11.0.0/24 is subnetted, 1 subnets
C 172.11.0.0 is directly connected, FastEthernet0/0
192.168.1.0/30 is subnetted, 1 subnets
C 192.168.1.0 is directly connected, Serial1/0
R2#
-라우터 3번 설정-
Router>enable
Router#configure
Configuring from terminal, memory, or network [terminal]? t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname R3
R3(config)#enable secret cisco
R3(config)#no ip domain lookup
R3(config)#line console 0
R3(config-line)#no login
R3(config-line)#exec-timeout 0 0
R3(config-line)#logging synchronous
R3(config-line)#exit
R3(config)#line vty 0 4
R3(config-line)#no login
R3(config-line)#exit
R3(config)#
R3(config)#interface loopback 0
R3(config-if)#ip
*Mar 1 00:12:19.927: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback0, changed state to up
R3(config-if)#ip address 172.12.0.1 255.255.255.0
R3(config-if)#exit
R3(config)#interface serial 1/0
R3(config-if)#ip address 192.168.1.6 255.255.255.252
R3(config-if)#bandwidth 2048
R3(config-if)#encapsulation hdlc
R3(config-if)#no shutdown
R3(config-if)#end
R3#
*Mar 1 00:13:50.083: %SYS-5-CONFIG_I: Configured from console by console
R3#
*Mar 1 00:13:50.223: %LINK-3-UPDOWN: Interface Serial1/0, changed state to up
R3#
*Mar 1 00:13:51.231: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial1/0, changed state to up
R3#copy runnig-config startup-c
*Mar 1 00:14:14.099: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial1/0, changed state to down
R3#copy runnig-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK]
R3#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
172.12.0.0/24 is subnetted, 1 subnets
C 172.12.0.0 is directly connected, Loopback0
R3#
라우터 R1, R2, R3 을 설정을 하면 serial으로는 ping이 가능하지만, 나머지 loopback 과 fastethernet 으로는 ping이 되지 않습니다..
아래는 staitc 으로 설정해보겠습니다.
- 라우터 1번 -
R1#config
Configuring from terminal, memory, or network [terminal]? t
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#ip route 172.11.0.0 255.255.255.0 serial 1/0
R1(config)#ip route 172.12.0.0 255.255.255.0 serial 1/1
R1(config)#end
R1#
*Mar 1 00:31:24.683: %SYS-5-CONFIG_I: Configured from console by console
R1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
172.11.0.0/24 is subnetted, 1 subnets
S 172.11.0.0 [1/0] via 192.168.1.2
is directly connected, Serial1/0
10.0.0.0/24 is subnetted, 1 subnets
C 10.10.10.0 is directly connected, Loopback0
192.168.1.0/30 is subnetted, 1 subnets
C 192.168.1.0 is directly connected, Serial1/0
- 라우터 2번 -
R2#
R2#config
Configuring from terminal, memory, or network [terminal]? t
Enter configuration commands, one per line. End with CNTL/Z.
R2(config)#ip route 10.10.10.0 255.255.255.0 serial 1/0
R2(config)#ip route 192.168.1.4 255.255.255.252 serial 1/0
R2(config)#ip route 172.12.0.0 255.255.255.0 serial 1/0
R2(config)#end
R2#
*Mar 1 00:35:56.979: %SYS-5-CONFIG_I: Configured from console by console
R2#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
172.11.0.0/24 is subnetted, 1 subnets
C 172.11.0.0 is directly connected, FastEthernet0/0
172.12.0.0/24 is subnetted, 1 subnets
S 172.12.0.0 is directly connected, Serial1/0
10.0.0.0/24 is subnetted, 1 subnets
S 10.10.10.0 is directly connected, Serial1/0
192.168.1.0/30 is subnetted, 2 subnets
C 192.168.1.0 is directly connected, Serial1/0
S 192.168.1.4 is directly connected, Serial1/0
R2#
- 라우터 3번 -
-- R1 Router --
S 172.11.0.0/24 => R2 f0/0
R1 s1/0 (out) -> R2 s1/0 (in) -> R2 f0/0 (out) ==> D : 172.11.0.0/24
=> Router(config)# ip route 172.11.0.0 255.255.255.0 serial 1/0
Router(config)# ip route 172.11.0.0 255.255.255.0 192.168.1.2
S 172.12.0.0/24 => R3 lo/0
R1 s1/1 (out) -> R3 s1/0 (in) -> R3 lo/0 (out) ==> D : 172.12.0.0/24
=> Router(config)# ip route 172.12.0.0 255.255.255.0 serial 1/1
=> Router(config)# ip route 172.11.0.0 255.255.255.0 192.168.1.6
-- R2 Router --
C 172.11.0.0/24
C 192.168.1.0/30
S 10.10.10.0/24 => R1 lo/0
R2 s1/0 (out) -> R1 s1/0 (in) -> R1 lo/0 (out) ==> D : 10.10.10.0/24
=> Router(config)# ip route 10.10.10.0 255.255.255.0 serial 1/0
=> Router(config)# ip route 10.10.10.0 255.255.255.0 192.168.1.1
S 192.168.1.4/30 => R1 s1/1
R2 s1/0 (out) -> R1 s1/0 (in) -> R1 s1/1 (out) ==> D : 192.168.1.4/30
=> Router(config)# ip route 192.168.1.4 255.255.255.252 serial 1/0
Router(config)# ip route 192.168.1.4 255.255.255.252 192.168.1.1
S 172.12.0.0/24 => R3 lo/0
R2 s1/0 (out) -> R1 s1/0 (in) -> R1 s1/1 (out) -> R3 s1/0 (in) -> R3 lo/0 (out) ==> D : 172.12.0.0/24
=> Router(config)# ip route 172.12.0.0 255.255.255.0 serial 1/0
Router(config)# ip route 172.12.0.0 255.255.255.0 192.168.1.1
-- R3 Router --
C 172.12.0.0/24
C 192.168.1.4/30
S 10.10.10.0/24 => R1 lo/0
R3 s1/0 (out) -> R1 s1/1 (in) -> R1 lo/0 (out) ==> D : 10.10.10.0/24
=> Router(config)# ip route 10.10.10.0 255.255.255.252 serial s1/0
Router(config)# ip route 10.10.10.0 255.255.255.252 192.168.1.5
S 192.168.1.0/30 => R1 s1/0
R3 s1/0 (out) -> R1 s1/1 (in) -> R1 s1/0 (out) ==> D : 192.168.1.0/30
=> Router(config)# ip route 192.168.1.0 255.255.255.252 serial s1/0
Router(config)# ip route 192.168.1.0 255.255.255.252 192.168.1.5
S 172.11.0.0/24 => R2 s1/0
R3 s1/0 (out) -> R1 s1/1 (in) -> R1 s1/0 (out) -> R2 s1/0 (in) -> R2 lo/0 (out) ==> D : 172.11.0.0/24
=> Router(config)# ip route 172.11.0.0 255.255.255.0 serial 1/0
Router(config)# ip route 172.11.0.0 255.255.255.0 192.168.1.5v
'工夫 > Network' 카테고리의 다른 글
utp케이블 규격 (0) | 2009.12.27 |
---|---|
Packet Tracer 를 이용한 라우터 연결 2 (0) | 2009.08.02 |
Dynamips-Basic 1 (0) | 2009.08.02 |
Dynamips 설치하기 (0) | 2009.08.02 |
Router 추가부팅 과정 (0) | 2009.08.01 |
댓글